Cleanup of autoconf files
[emu8051.git] / src / common / Makefile.am
index 267c498..68f8191 100644 (file)
@@ -1,40 +1,48 @@
 # This file is processed by GNU automake to generate Makefile.in
 
 AM_CPPFLAGS = \
-       $(WARNINGCFLAGS) \
-       -I$(top_srcdir)
+    $(WARNINGCFLAGS) \
+    -I$(builddir)
+
+VPATH = $(srcdir) $(builddir)
 
 noinst_LIBRARIES = libemu8051.a
 
+BUILT_SOURCES = \
+    instructions_8051.c instructions_8051.h \
+    opcodes.h opcodes.c
+
+PERL_SOURCES = \
+    opcodes2c.pl \
+    opcodes.lst
+
 libemu8051_a_SOURCES = \
-       instructions_8051.c instructions_8051.h \
-       opcodes.c opcodes.h \
-       options.c options.h \
-       log.c log.h \
-       hexfile.c hexfile.h \
-       cpu8051.c cpu8051.h \
-       memory.c memory.h \
-       psw.c psw.h \
-       sfr.c sfr.h \
-       operations.c operations.h \
-       timers.c timers.h \
-       common.h \
-       reg8051.h
+    options.c options.h \
+    log.c log.h \
+    hexfile.c hexfile.h \
+    cpu8051.c cpu8051.h \
+    memory.c memory.h \
+    psw.c psw.h \
+    sfr.c sfr.h \
+    operations.c operations.h \
+    timers.c timers.h \
+    common.h \
+    reg8051.h
+
+nodist_libemu8051_a_SOURCES = \
+    $(BUILT_SOURCES)
 
 # These files are generated automatically by a perl script.
-instructions_8051.c instructions_8051.h opcodes.h opcodes.c : opcodes2c.pl opcodes.lst
+$(BUILT_SOURCES) : $(PERL_SOURCES)
        @echo "  PERL     opcodes2c.pl"
-       @./opcodes2c.pl
+       @$(srcdir)/opcodes2c.pl $(srcdir)/opcodes.lst $(builddir)
 
-CLEANFILES = *~
+CLEANFILES = \
+    *~ \
+    $(BUILT_SOURCES)
 
 MAINTAINERCLEANFILES = \
-       Makefile.in \
-       instructions_8051.c \
-       instructions_8051.h \
-       opcodes.h \
-       opcodes.c
+    Makefile.in
 
 EXTRA_DIST = \
-       opcodes2c.pl \
-       opcodes.lst
+    $(PERL_SOURCES)