Add support for as504 assembler, with output file option
[emu8051.git] / tests / Makefile.am
index 514384f..6c3da20 100644 (file)
@@ -30,8 +30,11 @@ TESTS = \
 
 # Tell make how to generate a .hex file from a .asm source file.
 # Warning: make distcheck will fail because asem nor as504 have option to
-# specify output filename (and path):
+# specify output filename (and path), except patched version of as504:
 .asm.hex:
+if USE_AS504HV
+       $(AS504) -Fhex -O$@ $<
+else
 if USE_AS504
        $(AS504) -Fhex $<
 else
@@ -41,6 +44,7 @@ else
        echo error
 endif
 endif
+endif
 
 else
 TESTS =